В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Pazitifon3000
Pazitifon3000
27.11.2020 17:27 •  Информатика

Дан массив в, содержащий 2 строки и 4 столбца. составить программу нахождения суммы элементов этого массива. сделать, желательно с объяснениями, просто пропустил эту тему: (

Показать ответ
Ответ:
Kr1c
Kr1c
17.09.2020 06:52
// PascalABC.Net 3.0, сборка 1066
begin
  var a:=MatrixRandom(2,4,-25,25);
  Writeln('Исходная матрица: ',a);
  var s:=0;
  for var i:=0 to 1 do
  for var j:=0 to 3 do
    s+=a[i,j];
  Writeln('Сумма элементов равна ',s)
end.

Тестовое решение:
Исходная матрица: [[-15,-12,-9,5],[-8,-3,-23,7]]
Сумма элементов равна -58
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота