В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
darkelan
darkelan
19.04.2022 02:57 •  Информатика

Дан массив, состоящий из N целых чисел, количество элементов вводится с клавиатуры. Составить программу, в которой будут реализованы следующие действия:
а) заполнение массива случайными числами и вывод полученного массива на экран;
б) подсчет количества тех элементов массива, значения которых больше заданного числа x (вводит пользователь с клавиатуры) и одновременно кратны 5;

Показать ответ
Ответ:
evdokiya888p06xhz
evdokiya888p06xhz
25.06.2022 05:32
Последовательности длиной 7, содержащей 5 букв А могут быть следующими:
** (* - любой из символов В или С)
*А*
ААА*АА*
АА*ААА*
А**
** (пока 6 вариантов)
Далее - аналогично:
**А
ААА*А*А
АА*АА*А
А*ААА*А
**А (ещё 5 вариантов)
ААА**АА
АА*А*АА
А*АА*АА
*ААА*АА (ещё 4 варианта)
АА**ААА
А*А*ААА
*АА*ААА (ещё 3 варианта)
А**
*А* (ещё 2)
** (ещё 1)
Итого: 6+5+4+3+2+1=21
Так как на месте * могут быть любые из 2 символов В или С, то это даст ещё по 4 варианта для каждого случая.
Можно здесь, конечно, комбинаторику вспомнить.
Итого: 21*4 = 84
0,0(0 оценок)
Ответ:
avomilag95
avomilag95
11.01.2023 07:35
Program pr;
uses crt;

var a,b:real;

Begin
writeln('Введите первое число');
readln(a);
writeln('Введите второе число');
readln(b);

if (a<0) and (b<0)   
    then     
       Begin       
            a:=a+2;
            b:=b+2; 
             writeln('a = ',a); 
             writeln('b = ',b); 
        end
else 
      if (a>0) and (b<0)     
        then       
           writeln('a*b = ',a*b)
      else 
           if (a<0) and (b>0)     
                then        
                   writeln('b-a = ', b-a)

           else  writeln('Ни одно условие не выполняется');

readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота