В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
zeinalovazahra
zeinalovazahra
26.11.2020 18:51 •  Информатика

Дан массив mas[1..10]: = 1,3,-1,4,0,-4,-4,3,0,-4. укажите, чему будет равно k после выполнения алгоритма. в ответе укажите число. k: = 1; for i: = 9 downto 1 do for j: =1 to i do if mas[j] > mas[j+1] then begin tmp: = mas[j]; mas[j]: = mas[j+1]; mas[j+1]: = tmp; k: = k + 1; end; write('k = ', k); readln

Показать ответ
Ответ:
lolo105
lolo105
02.10.2020 09:32
Это разновидность сортировки обменом - худший её вариант с точки зрения скорости и самый простой для написания: сортировка методом пузырька. Ручной подсчет значения k - количества сделанных в процессе сортировки обменов местами элементов массива, достаточно утомителен, поэтому проще добавить необходимые операторы и выполнить программу.
ответ: k=28
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота