Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
anisimanis
16.12.2021 11:04 •
Информатика
Дан массив из n элементов. найти сумму элементов с четными номерами и отдельно – с нечетными номерами
Показать ответ
Ответ:
muxtarova2007
05.10.2020 06:12
#include <stdio.h>
#include <string.h>
#include <iostream>
void main() {
int a[100];
int b = 0, c = 0;
bool change = false;
for (int i = 0; i < 100; ++i) {
if (!change) {
++b;
} else {
++c;
}
++a[i];
change = !change;
}
printf("4eTHble: %d | He 4eTHble: %d", b, c);
getchar();
0,0
(0 оценок)
Популярные вопросы: Информатика
ImmortalSpirit
01.06.2022 19:42
Расположите величины в порядке возрастания: 1010 байтов, 2 байта, 1кбайт, 20 битов, 10 битов....
Лизончик111
13.06.2020 18:33
Сократить логическую функцию: (x→¬y)⊕(z∨y)...
HanZamay
23.02.2023 20:19
Напишите программу, которая заполняет массив случайными числами на отрезке [-2; 2] и считает сумму положительных элементов массива. (паскаль 9 класс) типо этого...
софияпрекрасная15
02.05.2023 20:27
Из символов двоичного алфавита можно составить различных трёхбуквенных слов. не более четырёх не менее шестнадцати не более двух не более восьми...
arinochkakor1
06.06.2023 03:02
Зчого складається простіша крива безьє...
zalinairina9
03.11.2021 12:40
Блок схема ввести з клавіатури 5 чисел. визначити чи є серед них число 2....
Maria120163
08.10.2022 15:40
Перепишите 5, чтобы сделать выбор между левым и правым выравниванием чисел...
kosikoffpasha
30.05.2022 20:28
Знание и понимание )1. что такое беспроводная сеть? 2. в чем преимущества беспроводной сети перед проводной? 3. какие топологии беспроводных сетей вы знаете? 4. в каких...
ivanivanlushch
14.12.2021 05:37
Фраторы графики.docx — открыть в приложении соор Вариант 1 1. Начертите изображение в графическом режиме 7. Цвет линий, квадратов серый. Цвет окружностей красный. Цвет...
ddawka
16.07.2022 22:42
Запишите следующие числа в естественной форме: а) 1,1285 .105 б) 61,103 . 10-2 в)2,4700Е+3 г) 36,7872Е-4...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <string.h>
#include <iostream>
void main() {
int a[100];
int b = 0, c = 0;
bool change = false;
for (int i = 0; i < 100; ++i) {
if (!change) {
++b;
} else {
++c;
}
++a[i];
change = !change;
}
printf("4eTHble: %d | He 4eTHble: %d", b, c);
getchar();