В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
katuxa65789
katuxa65789
19.10.2020 11:42 •  Информатика

Дан массив из 30 элементов из интервала[-15;15].Составить программу нахождение суммы отрицательных элементов,больших ответьте

Показать ответ
Ответ:
ScRoller
ScRoller
27.01.2022 15:33

pascal

Объяснение:

var i, s: integer;

   a: array[1..30] of integer;

begin

 randomize;

 for i := 1 to 30 do

 begin

   a[i] := random(31) - 15;

   Write(a[i], ' ');

   if (a[i] > -9) and (a[i] < 0) then s := s + a[i];

 end;

 WriteLn;

 WriteLn('Сумма отрицательных элементов,больших -9, равна ', s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота