В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
chudmaev2003
chudmaev2003
11.02.2022 09:36 •  Информатика

Дан массив из 12 элементов, в котором есть положительные и отрицательные числа (ноль тоже есть): а1=5, а2=4, а3=-3, а4=1, а5=0, а6=-4, а7=, а8=25, а9=-8, а10=-5, а11=-17, а12=-1. составьте программу, в которой 1 вариант: все отрицательные числа меняются на «1», все положительные на «-5», нулевые не трогаются. вывести на экран исходный и полученный массив.

Показать ответ
Ответ:
банан116
банан116
15.09.2020 21:20
Const n=12;
a:array[1..n] of integer=(5,4,-3,1,0,-4,7,25,-8,-5,-17,-1);
var i:integer;
begin
for i:=1 to n do write(a[i]:4);
writeln;
for i:=1 to n do
 if a[i]<0 then a[i]:=1
           else if a[i]>0 then a[i]:=-5;
for i:=1 to n do write(a[i]:4);
end.

Результат:
5 4 -3 1 0 -4 7 25 -8 -5 -17 -1
-5 -5 1 -5 0 1 -5 -5 1 1 1 1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота