Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
jojo31
15.11.2021 03:37 •
Информатика
Дан массив из 10 вещественных чисел. посчитать сумму элементов массива с черными номерами
Показать ответ
Ответ:
avamini2007
26.08.2020 19:09
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrReal('Введите 10 чисел:',10);
Writeln('Искомая сумма равна ',a.Where((x,i)->i.IsOdd).Sum)
end.
Пример
Введите 10 чисел: 3.6 -1.45 2.11 6 3.9 -12.65 4.1 -5 0 11.3
Искомая сумма равна -1.8
0,0
(0 оценок)
Ответ:
MASKARAD2211
26.08.2020 19:09
// PascalABC.NET 3.3, сборка 1576 от 16.11.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:= ArrGen(10, t -> ReadReal);
var ans:= a.where((v,i) -> (i + 1).IsEven).sum;
Writeln('Сумма элементов с четными номерами: ', ans);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
веселаямышка
14.05.2023 19:22
Найти сумму всех чисел от 1 до заданного n которые делятся на 3 и не делятся на 5...
messor06
13.03.2022 05:19
Сначала приведены примеры решения с формулировкой задач, на основе примеров выполнить задания указанные ниже Задача 1. Из N целых чисел найти минимальное значение. VAR...
aiis171
22.10.2022 14:28
Сколько цветов в палитре если цветное изображение имеет размер 20 на 30 точек, а информационный объем равен 150 байт?...
dania45451
15.02.2023 09:21
Какой объем памяти необходим для хранения растрового изображения состоящего из 512 х 512 пикселей, если при этом использовалась палитра 256 цветов? Запишите дано, формулу,...
HunterX05
17.03.2020 06:40
Напишите программу подсчета количества положительных, отрицательных чисел и чисел, равных нулю. Ввод чисел с клавиатуры....
Angelina07111
29.05.2023 21:08
Исполнитель Редактор получает на вход строку цифр и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки цифр. заменить...
VERLIA
10.07.2022 00:41
ТЕСТ : 1. свойства информации : А) ПОНЯТНО, Б ) ДОСТОВЕРНО, В) АКТУАЛЬНО, Г) ПОЛЕЗНО,Д ) ПОЛНО, Е) СООБЩЕНИЕ ОБЪЕКТИВНО, ЕСЛИ ОНО ВАЖНО, СУЩЕСТВЕННО ДЛЯ НАСТОЯЩЕГО ВРЕМЕНИ....
Hamster02
21.07.2020 21:21
Какое расширение принадлежит текстовому файлу?a) zip6) docxe) jpeg r) mp3д) avi...
kravchenkomiss
30.12.2021 11:40
Задача по Питону Багаж пассажира характеризуется количеством вещей и общим их весом. Организовать хранение данных о багаже нескольких пассажиров. Найти количество пассажиров,...
smirnovaanastas5
22.10.2021 00:43
Базовим елементом якого виду графіки є трикутник? ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrReal('Введите 10 чисел:',10);
Writeln('Искомая сумма равна ',a.Where((x,i)->i.IsOdd).Sum)
end.
Пример
Введите 10 чисел: 3.6 -1.45 2.11 6 3.9 -12.65 4.1 -5 0 11.3
Искомая сумма равна -1.8
// Внимание! Если программа не работает, обновите версию!
begin
var a:= ArrGen(10, t -> ReadReal);
var ans:= a.where((v,i) -> (i + 1).IsEven).sum;
Writeln('Сумма элементов с четными номерами: ', ans);
end.