В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Damira123451
Damira123451
04.02.2020 10:58 •  Информатика

Дан массив из 10 элементов. составить программу которая даёт ответ на вопрос есть ли в массиве более одного элемента равного максимальному. ответ выводится в виде да/нет. pascal.

Показать ответ
Ответ:
Виолета131
Виолета131
07.10.2020 10:28
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(10,1,9); a.Println;
  if a.Where(t->t=a.Max).Count>1 then
    Writeln('Есть элементы, равные максимальному')
  else
    Writeln('Нет элементов, равных максимальному')
end.

Примеры
5 5 6 4 4 1 6 9 8 3
Нет элементов, равных максимальному

1 8 1 5 2 3 1 4 5 8
Есть элементы, равные максимальному
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота