Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Ученицав
13.09.2022 04:29 •
Информатика
Дан массив действительных чисел размерностью n. подсчитать, сколько в нем отрицательных, положительных и нулевых элементов c++
Показать ответ
Ответ:
Chemist2001
09.10.2020 07:09
#include <iostream>#include <array>#include <algorithm>#include <functional>template <std::size_t size>int count(std::array<int, size> const& arr_, std::function<bool(int)> const& f){ return std::count_if(arr_.begin(), arr_.end(), f);}int main(){ std::array<int, 5> arr = { -2, 0, 5, 0, -1 }; int positive = count(arr, [](int a){ return a > 0; }); int negative = count(arr, [](int a){ return a < 0; }); int zero = count(arr, [](int a){ return a == 0; }); std::cout << positive << " " << negative << " " << zero;}
0,0
(0 оценок)
Популярные вопросы: Информатика
mhjkglckktcfcmjkfg
21.02.2020 08:23
те , сор по инфе 7 кл 1 четверть...
danil2009cot
14.12.2021 02:31
Как в паскале удалить цифру из числа? какая для этого команда? : )...
flower57
13.10.2021 18:04
Два игрока, петя и ваня, играют в следующую игру. перед игроками лежит куча камней. игроки ходят по очереди, первый ход делает петя. за один ход игрок может добавить в кучу...
VikaTomaRetaSasha
15.12.2020 15:36
Разгадайте кроссворд рис 1.12...
kabirova2356
12.10.2020 13:52
Uses crt; var i_put,o_put: string; i,s_ch,n: byte; flag: boolean; begin clrscr; writeln( vvedite stroku: ); readln(i_put); flag: =true; while flag do begin flag: =false; s_ch:...
trul85
08.02.2020 02:27
Дана строка, состоящая из строчных латинских букв и пробелов. проверьте, является ли она палиндромом без учета пробелов (например, аргентина манит негра ).входные данныена...
Отличница4561
07.09.2020 09:46
Требуется найти число расставить на шахматной доске nxn k ладей так, чтобы они не били друг друга. все ладьи считаются одинаковыми.входные данныево входном файле записаны...
123443123
02.01.2022 21:57
Максим любит коллекционировать вещи с необычными замками. Он решил разобрать свою коллекцию и нашел шкатулку, которую покупал так давно, что уже забыл, как она открывается....
2006ksenia2006
07.06.2022 11:53
Федя совсем недавно поступил в лучший вуз страны. В особенности ему стала интересна кафедра изучения счастливых чисел, то есть тех чисел, которые состоят только из цифр 2...
magiklen
15.08.2020 06:24
Сдать решение задачи C1-Гипотеза Коллатца Задача C1: Гипотеза Коллатца Недавно Ваня наткнулся на интересную гипотезу, являющуюся одной из нерешенных проблем математики. Она...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота