В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nastusya1709
nastusya1709
15.03.2023 13:52 •  Информатика

Дан массив d(n). найти минимальный среди элементов, больших суммы,и найти количество элементов, не равных максимальному. написать программу в паскале,)

Показать ответ
Ответ:
tim2424
tim2424
10.06.2020 13:03

program raf105;

const

 n = 10;

var

 d:array[1..n] of integer;

 min,max,sum,notmax,i: integer;

begin

max:= -10000;

min:= 10000;

writeln('Заполните массив');

for i:=1 to n do

begin

 readln(d[i]);

 sum+= d[i];

 if max<d[i]

   then max:= d[i];

end;

for i:=1 to n do

begin

 if d[i]<>max

   then notmax+= 1;

 if (d[i]>sum) and (d[i]<min)

   then min:= d[i];

end;

if min<>10000

 then writeln('Минимальный среди элементов, больших суммы: ',min)

 else writeln('Минимальный среди элементов, больших суммы: Не найдено');

writeln('Количество элементов, не равных максимальному: ',notmax);

end.

Язык PascalABC
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота