В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
taush
taush
15.06.2022 23:03 •  Информатика

Дан массив чисел A. Нам необходимо определить текущую сумму элементов массива ArraySum [i] = sum (A[0]… A[i]). Верните массив с текущей суммой чисел. Текущая сумма получается следующим образом: Массив A состоит из элементов 1,2,3,4. Результат суммирования А = 1,3,6,10. То есть 1, 1+2 (3), 1+2+3 (6), 1+2+3+4 (10). Входные данные В единственной строке входного файла INPUT записан массив А из целых чисел 1 <=Длина массива <= 1000. Элементы массива -10^6 <= А[i] <= 10^6. Выходные данные В единственную строку выходного файла OUTPUT нужно вывести массив А удовлетворяющий условию.


Дан массив чисел A. Нам необходимо определить текущую сумму элементов массива ArraySum [i] = sum (A[

Показать ответ
Ответ:
dghtf
dghtf
03.12.2020 10:45

N = input().split(',')

arr = []

arr2 = []

for i in N:

   i = int(i)

   n = sum(arr2) + i

   arr2.append(i)

   arr.append(n)

print(arr)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота