В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
фифа1
фифа1
30.09.2021 01:36 •  Информатика

Дан массив целых чисел из n элементов сформированный случайным образом. определить, сколько в нем чисел кратных 7 написать программу в паскаль

Показать ответ
Ответ:
Юлия7791
Юлия7791
08.10.2020 07:02
Var
  a, k, n, i, sum: integer;
 
begin
  read(n, k);
  for i := 1 to n do
  begin
    read(a);
    if a mod k = 0 then sum := sum + a;
  end;
  writeln(sum) ;
end.

где k - заданное число которому должны быть кратны элементы массива
n - кол-во элементов массива
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота