Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
PooКякя
21.07.2020 13:49 •
Информатика
Дан массив целых чисел из 17 элементов. определить частное от деления суммы положительных элементов массива на модуль суммы отрицательных элементов
Показать ответ
Ответ:
nOMOshHuK2
03.10.2020 07:52
На Паскале
var a: array [1..5] of integer;
i: integer;
p, m: integer;
begin
for i:=1 to 5 do begin
readln(a[i]);
If a[i] < 0 then
m:= m+a[i]
else
p:=p+a[i];
end;
writeln(p/abs(m));
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
yafifiya
24.01.2021 07:15
Шифрования, который часто используют начинающие криптографы, заклю- чается в том, что шифруемое слово записывается некоторым достаточно хитрым образом в клетках квадрата. Одним...
55d
20.08.2021 01:45
Количество чисел На вход программе подаются два целых числа aa и bb (a \le b)(a≤b). Напишите программу, которая подсчитывает количество чисел в диапазоне от aa до bb включительно,...
vovamakarevich
05.05.2023 16:06
Виконати перетворення чисел з десяткової системи числення в шістнадцятирічну систему числення, та зробити обратне перетворення: 62; 38; 50; 196; 147; 134; 562; 678; 748...
Алгебра111111111
27.11.2021 16:41
Полноцветное rgb - изображение ( 8 бит на цвет ) размером 1024 на 768 было сохранено в файле в формате jpeg , размер которого оказался равным 36 кибибайт. определите, во сколько...
anas20041006
05.01.2021 09:54
Составить блок - схему: найти s и p равнобедренной трапеции с основаниями a и b (a b) и острым углом alpha (угол дан в радианах)...
manilowyn2
05.01.2021 09:54
Pascal. дана строка из строчных букв. между соседними словами - запятая, за последним словом - точка. составить программу, печатающую в алфавитном порядке: 1. все гласные буквы,...
ОстановитеЭтотМир
28.08.2022 10:23
Написать программу, которая находит сумму кубов всех целых чисел от а до 60. значение а вводится с клавиатуры, 0 =a =60 решать через цикл с постусловием ()...
tetysheva09
03.05.2021 12:25
Розкрити морально-філосовський зміст притчі про блудного сина 15р. ...
НяФФкА555
24.07.2022 18:37
Напишите 5 предложений об осенней погоде, используя метафору....
andriyana13
24.07.2022 18:37
Сетевая операционная система - это: 1. Совокупность ОС всех компьютеров сети; 2. ОС отдельного компьютера сети; 3. Набор сетевых служб, выполненных в виде оболочки; 4. Нет правильного...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var a: array [1..5] of integer;
i: integer;
p, m: integer;
begin
for i:=1 to 5 do begin
readln(a[i]);
If a[i] < 0 then
m:= m+a[i]
else
p:=p+a[i];
end;
writeln(p/abs(m));
end.