В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
bogdanka1503p08ifa
bogdanka1503p08ifa
21.05.2020 14:16 •  Информатика

Дан массив а состоящий из элементов n массив b состоящий из элементов m составить программу которая меняет порядок элементов на обратный (для ввода печати использовать функцию )в с++

Показать ответ
Ответ:
casualsicp
casualsicp
07.10.2020 05:24
Сначала вводится N(кол-во эл-в в массиве), потом сам массив a.
Потом вводится M и массив b.
Программа выводит перевернутые массивы a и b
Если будут вопросы пиши к комментариям.

#include <bits/stdc++.h>
using namespace std;
int main(){

int N;
cin >> N;
vector<int> a(N);
for (int i = 0; i < N; i++)
    cin >> a[i];
int M;
cin >> M;
vector<int> b(M);
for (int i = 0; i < M; i++)
    cin >> b[i];
reverse(a.begin(), a.end());
reverse(b.begin(), b.end());
for (int i = 0; i < N; i++)
    cout << a[i] << ' ';
    cout << endl;
for (int i = 0; i < M; i++)
    cout << b[i] << ' ';
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота