В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
228Aimer228
228Aimer228
28.11.2022 07:16 •  Информатика

Дан массив a(n). определите количество четных элементов с четными индексами, кратных 7. выведите на экран исходный массив и полученное количество.

Показать ответ
Ответ:
ilay23143p0bp8a
ilay23143p0bp8a
06.10.2020 03:03
Const n=10; 
var a:array[1..n] of integer;
i,k:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(51);
 write(a[i]:4);
 end;
writeln;
k:=0;
for i:=1 to n do
 if (a[i] mod 2=0)and(a[i] mod 7=0)and(i mod 2=0) then k:=k+1;
writeln('k = ',k);
end.

Пример:
Массив A:
25 29 13 39 9 14 27 16 12 45
k = 1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота