В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
andbliev
andbliev
11.02.2020 15:22 •  Информатика

Дан фрагмент программы бейсик паскаль алгоритмический нц для n от 1 до 5 for n=1 to 5 for n: =1 to 5 do нц для m от 1 до 4 for m=1 to 4 for m: =1 to 4 do k: =n-m+5 k=n-m+5 begin k: =n-m+5; b[n,m]: =n*n*n-m*m+k b(n,m)=n^3-m^2+k b[n,m]: =n*n*n-m*m+k; кц next m end кц next n чему будет равно значение b[1,4]? с полным решением ( написать всю программу на каждый вид ) !

Показать ответ
Ответ:
настя123456789108
настя123456789108
21.03.2022 05:26
Чтобы квадрат вписался в круг, его диагональ должна быть равна диаметру круга. Если трактовать "уместиться" как "пролезть", то диагональ должна быть меньше диаметра..
Формулы площадей квадрата  S₁ и круга S₂ известны, что легко позволяет нам найти нужное условие.
\displaystyle S_1=a^2 \to a=\sqrt{S_1}; \ d=a \sqrt{2}= \sqrt{2S_1} \\ S_2=\frac{\pi D^2}{4} \to D=\sqrt{\frac{4S_2}{\pi}}; \\ d\ \textless \ D \to \sqrt{2S_1}\ \textless \ \sqrt{\frac{4S_2}{\pi}}; \ 2S_1\ \textless \ \frac{4S_2}{\pi} \ \to \ \boxed{\pi s_1\ \textless \ 2S_2}
Если нужно, чтобы случай, когда квадрат вписан в круг тоже учитывался, строгое неравенство следует заменить нестрогим.

// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
  var s1:=ReadReal('Площадь квадрата');
  var s2:=ReadReal('Площадь круга');
  if pi*s1<2*s2 then Writeln('Квадрат умещается в круге')
  else Writeln('Квадрат не умещается в круге')
end.

Тестовое решение:
Площадь квадрата 24.6
Площадь круга 28.4
Квадрат не умещается в круге
0,0(0 оценок)
Ответ:
elenaklass1
elenaklass1
07.10.2022 08:38

Тәжірибеден көптеген пайдаланушылар әрдайым ноутбукте антивирус орнатпайды деп айтуға болады, себебі ноутбуктің бәрі тез емес, бірақ антивирус оны баяулатады, және олар бейтаныс сайттарға кірмейтінін, файлдарды жүктемейтінін - бұл дегеніміз, және вирус алмайды (бірақ әдетте керісінше болады ...).

Айтпақшы, кейбір адамдар тіпті вирустардың ноутбугына «қоныстанған» деп күмән келтірмейді (мысалы, олар барлық желілерде пайда болатын жарнамалар сол сияқты болуы керек деп ойлайды). Сондықтан мен осы ескертуді эскиздеуге шешім қабылдадым, онда мен вирустардан және басқа желілерде жиналуы мүмкін басқа «жұқтырулардан» ноутбуктарды алып тастау және тазарту үшін не істеу керектігін түсіндіремін.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота