В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
aasssddddddd
aasssddddddd
18.04.2022 08:05 •  Информатика

Дан двумерный массив размерностью 8х12, инициализированный целочисленными значениями из диапазона от -20 до +80. Написать программу, которая ищет минимальный четный элемент этого массива и выводит на экран его значение и его координаты.

сделать в паскале

Показать ответ
Ответ:
elya144
elya144
13.10.2020 17:31

pascal

Объяснение:

var

 min: integer;

 i, j, k, l: integer;

 a: array[1..8,1..12] of integer;

begin

 min := 81;

 for i := 1 to 8 do begin

   for j := 1 to 12 do

     begin

      a[i, j] := random(101) - 20;

      Write(a[i, j]:4);

      if (a[i, j] < min) and (a[i, j] mod 2 = 0) then

      begin

        min := a[i, j];

        k := i;

        l := j;

      end;

     end;

   WriteLn;

  end;

  WriteLn('Минимальный четный элемент - A[',k,',',l,']=',min);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота