В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Sasno228666
Sasno228666
13.07.2021 15:55 •  Информатика

Дан двумерный массив из m строк и n столбцов. Скопировать элементы заданного массива в одномерный массив размером m×n . Копирование проводить следующим образом: по столбцам начиная с первого (а в них — с крайнего верхнего элемента). Формат входных данных
На первой строке входного файла даны два целых числа m и n (1≤m,n≤100). На следующих m строках дано по n целых чисел — элементы массива. Все числа по модулю не превосходят 100.
Формат выходных данных
Выведите m×n чисел — заполненный соответствующим образом одномерный массив.
входные данные
5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
выходные данные
1 16 15 14 13 2 17 24 23 12 3 18 25 22 11 4 19 20 21 10 5 6 7 8 9

Показать ответ
Ответ:
Natashhkka
Natashhkka
16.08.2022 13:19

1. Лабири́нт (др.-греч. λαβύρινθος) — какая-либо структура (обычно в двухмерном или трёхмерном пространстве), состоящая из запутанных путей к выходу (и/или путей, ведущих в тупик). Под лабиринтом у древних греков и римлян подразумевалось более или менее обширное пространство...

2. Нужен дачик ультрозвуковой можно использовать как альтернативу дачик касания, если лабиринт одного цвета то можно использовать дачики цвета.Из этих дачиков можно проходить лабиринт главное разобраться в програмировании робота и какой тебе удобно дадчик.лично я бы использовал дачик цвета и касания.

3. Правило правой руки или одной руки.

Универсальный алгоритм прохождения любых лабиринтов был описан только через столетие в книге французского математика Э. Люка "Recreations matematiques", изданной в 1882 году. Интересно, что Люка при описании алгоритма указал на первенство другого французского математика М. Тремо. Таким образом, алгоритм стал известен как алгоритм Люка-Тремо.

Тремо предлагает следующие правила: выйдя из любой точки лабиринта, надо сделать отметку на его стене (крест) и двигаться в произвольном направлении до тупика или перекрестка; в первом случае вернуться назад, поставить второй крест, свидетельствующий, что путь пройден дважды - туда и назад, и идти в направлении, не пройденном ни разу, или пройденном один раз; во втором - идти по произвольному направлению, отмечая каждый перекресток на входе и на выходе одним крестом; если на перекресте один крест уже имеется, то следует идти новым путем, если нет - то пройденным путем, отметив его вторым крестом.

Объяснение:

0,0(0 оценок)
Ответ:
mxnty
mxnty
27.03.2023 11:05

А)

program num;

var

 number: integer;

begin

 read(number);

 if (number mod 2 = 0) then

   write('ДА')

 else

   write('НЕТ');

end.

Б)

program b;

var

 first, second: integer;

begin

 read(first, second);

 if (first > second) then

   write(first + second)

 else

   write(first * second);

end.

Объяснение:

А)

program num; // Название программы

var

 number: integer; // Целочисленная переменная, хранящая вводимое с клавиатуры число

begin // Начало программы

 read(number); // Считываем число с клавиатуры

 if (number mod 2 = 0) then // Если остаток от деления значения переменной number на 2 = 0, тогда

   write('ДА') // Выводим "Да"

 else // Иначе

   write('НЕТ'); // Выводим "Нет"

end. // Конец  программы

Б)

program b; // Название программы

var

 first, second: integer; // Целочисленные переменные, хранящие вводимые с клавиатуры числа

begin // Начало программы

 read(first, second); // Считываем числа с клавиатуры

 if (first > second) then // Если первое число > второго числа, тогда

   write(first + second) // Выводим сумму этих чисел

 else // Иначе

   write(first * second); // Выводим произведение этих чисел

end. // Конец  программы

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота