В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
09kok90
09kok90
31.12.2020 18:02 •  Информатика

Дан целочисленный прямоугольный массив 6x10. опишите в программе "паскальавс" алгоритм вычисления суммы минимальных элементов из каждой строки. напечатать значение этой суммы. предполагается, что в каждой строке минимальный элемент единственный.

Показать ответ
Ответ:
MariamAr81849
MariamAr81849
22.07.2020 08:28
Var 
a:array [1..6,1..10] of integer;  b,i,j,k,l: integer;  
begin 
 b:=0; 
 for i:=1 to 6 do 
 begin   
  k:=32000;   
  for j:=1 to 10 do   
  begin     
   read(l);     
   if (l<k) then k:=l;   
  end;   
  b+=k; 
 end; 
 write(b);
end.
Проверено:
1 2 3 4 5 6 7 8 9 10
10 9 8 7 6 5 4 3 2 1
1 2 3 4 5 6 7 8 9 10
10 9 8 7 6 5 4 3 2 1
1 2 3 4 5 6 7 8 9 10
10 9 8 7 6 5 4 3 2 1
ответ - 6
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота