Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
LexaCR7
24.11.2022 11:21 •
Информатика
Дан целочисленный массив размера n. вывести все содержащиеся в данном массиве четные числа в порядке убывания их индексов, а также их количество k.
Показать ответ
Ответ:
julia00221
03.08.2020 21:00
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!
begin;
var a:=ArrRandom(ReadInteger('n='),1,99); a.Println;
var k:=a.Where(x->x.IsEven).Reverse.Println.Count;
Writeln('k=',k)
end.
Пример
n= 15
25 97 33 31 92 87 70 44 75 65 26 77 48 84 39
84 48 26 44 70 92
k=6
0,0
(0 оценок)
Популярные вопросы: Информатика
jarretquinswid
25.09.2021 05:32
Каким является данный список? хлеб молоко конфеты а. маркированным b. нумерованным c. уровневым d. смешанным...
Диана1еее
08.04.2023 04:29
1.вычислить объем растрового изображения размером 200*110 точек и палитрой 128 цветов. 2.вычислить объем растрового черно-белого изображения размером 1000*862...
nikita1232534
08.04.2023 04:29
Заполнить массив 5 на 5 нулями выше диагонали, ниже главной диагонали единицами, диагональ звездочками...
taroslav
12.01.2020 19:06
Файл размером 4096 байт передаётся через некоторое соединение за 8 секунд. определите время в секундах, за которое можно передать через то же самое соединение файл размером 8 кбайт....
20setora03
23.01.2023 08:45
Паскаль Разработать программу вычисления значений заданных функций для произвольных значений исходных данных. Выполнить тестовый расчет и расчет для заданных значений исходных...
Nimixim
09.10.2020 15:21
PASCAL Составьте программу, которая найдет отношение двух ВВЕДЕННЫХ ЧИСЕЛ. оно должно быть больше 1 по модулю и должно существовать, то есть нужно делить большее число на меньшее...
Sanyaaa12
04.05.2022 23:30
Составьте проект, в котором исполнитель нарисует отрезок длиной 50 шагов синим цветом, якшцо нажата клавиша стрелка вправо, или нарисуйте отрезок длиной 100 шагов красным цветом,...
Rf123123
11.03.2023 13:07
Массовая доля цинка в его сплаве с медью составляет 58%. рассчитайте число атомов меди в таком сплаве массой 4,50г....
Cloud22
11.03.2023 13:07
Покажите порядок выполнения логических операций а \/ (b = c) /\ d == _а...
карим050
11.03.2023 13:07
Почему 12подвиг геракла назван самым трудным?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// Внимание! Если программа не работает, обновите версию!
begin;
var a:=ArrRandom(ReadInteger('n='),1,99); a.Println;
var k:=a.Where(x->x.IsEven).Reverse.Println.Count;
Writeln('k=',k)
end.
Пример
n= 15
25 97 33 31 92 87 70 44 75 65 26 77 48 84 39
84 48 26 44 70 92
k=6