В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
KristinaSchool
KristinaSchool
22.11.2022 01:04 •  Информатика

Дан целочисленный массив из 70 элементов.элементы массива могут принимать целые значения от 0 до 100.составить программу ,позволяющую найти и вывести элементы массива, которые не кратны 9 и находятся в диапазоне[30,70].гарантируется,что в исходном массиве есть хотя бы один такой элемент.

Показать ответ
Ответ:
valeria575
valeria575
01.10.2020 18:20
Const
    auto = true;
    n = 70;

var
    a: array[1..n] of integer;
    i: integer;

begin
    for i := 1 to n do
    begin
        if auto then
            a[i] := random(100)
        else readln(a[i]);
       
        if (a[i] <= 70) and (a[i] >= 30) and (a[i] mod 9 > 0) then
            writeln(a[i]);
    end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота