В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
artemklykmann
artemklykmann
17.04.2022 22:04 •  Информатика

Дан целочисленный массив из 30 элементов. Напишите программу, позволяющую найти наибольшее значение, которое является нечетным и делится на три. Язык PASCAL.

Показать ответ
Ответ:
оксаночка25
оксаночка25
23.02.2020 17:37

Объяснение:

1)При перекодировке сообщения из 8-битного кода в 16-битную кодировку UNICODE его объём увеличился на 2048 байтов.

2)Логин занимает объём памяти равной  = 20 * 5 бит = 100 бит (5 бит, т.к )

Аналогично с паролем, он занимает 15 * 4 бита = 60 бит памяти

Для хранения результатов выбора пола достаточно одного бита ( всего два возможных варианта() - ж или м,).

Итого одна учетная запись занимает: 100 + 60 +1 = 161 бит памяти.

Но в условии сказано, что она кодируется минимально возможным целым! кол-вом байт, значит: 161/8 = 20,125 байт, округляем в большую сторону - 21 байт.

Всего 30 записей: 21 * 30 = 630 байт.

Значит верный ответ под номером 3)

2)Т.к. на каждую из восьми позиций пароля можно поставить любую цифру из девяти (1,2,3,...,9 - всего 9 цифр), получаем количество комбинаций пароля  9^8=387420489

3) непомню(

0,0(0 оценок)
Ответ:
alisheralisher2
alisheralisher2
26.10.2020 17:36

#include <iostream>

#include <Windows.h>

using namespace std;

int num;

while(true) {

cin >> num;

cout << num << " x 1 = " << num * 1 << endl;

cout << num << " x 2 = " << num * 2 << endl;

cout << num << " x 3 = " << num * 3 << endl;

cout << num << " x 4 = " << num * 4 << endl;

cout << num << " x 5 = " << num * 5 << endl;

cout << num << " x 6 = " << num * 6 << endl;

cout << num << " x 7 = " << num * 7 << endl;

cout << num << " x 8 = " << num * 8 << endl;

cout << num << " x 9 = " << num * 9 << endl;

}

system("pause");

return 0;

Если что-то неправильно сделал, не суди, давно не программировал и уже особо не помню.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота