В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
stas7365w98
stas7365w98
23.07.2021 20:37 •  Информатика

Дан целочисленный массив из 20 элементов. элементы массива принимают значения от 0 до 10000 включительно. написать программу, позволяющую найти и вывести максимальное значение среди трехзначных элементов массива, делящихся на 4. если в исходном массиве нет трехзначного элемента, который делится на 4, то вывести сообщение о том, что такого числа нет.

Показать ответ
Ответ:
никотян7
никотян7
05.07.2020 01:54
Var
  max, i : integer;
  a : array [1..20] of integer;
begin
  max := -1;
  for i := 1 to 20 do read (a[i]);
  for i := 1 to 20 do
    if (a[i] < 1000) and (a[i] > 99) and (a[i] mod 4 = 0) and (a[i] > max) then
      max := a[i];
  if max > -1 then write (max) else write ('Nety');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота