В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
дашик27
дашик27
08.10.2022 21:57 •  Информатика

Дан целочисленный линейный массив из 10 элементов. найдите наименьшее число k элементов, которое нужно исключить из последовательности a[1], a[2],…,a[10], чтобы осталась возрастающая последовательность.язык delphi или паскаль буду признателен

Показать ответ
Ответ:
shubiiin
shubiiin
17.03.2023 10:06

1)

var

  a: 100..999;

  a1, a2, a3: 0..9;   //а1 - сотни, а2 - десятки, а3 - единицы

 

begin

  writeln('введите натуральное трехзначное число');

  readln(a);

  a1: = a div 100;

  a2: = (a mod 100) div 10;

  a3: = a mod 10;

  writeln('полученное число:   ', a1, a3, a2);

end.

2)

var

  a: 100..999;

  a1, a2, a3: 0..9;

 

begin

   

  writeln('введите натуральное трехзначное число');

  readln(a);

  a1: = a div 100;

  a2: = (a mod 100) div 10;

  a3: = a mod 10;

  writeln('полученное число:   ', a2, a1, a3);

end.

3)

var

  a: 100..999;

  a1, a2, a3: 0..9;

 

begin 

  writeln('введите натуральное трехзначное число');

  readln(a);

  a1: = a div 100;

  a2: = (a mod 100) div 10;

  a3: = a mod 10;

  writeln('полученное число:   ', a3, a1, a2, a3);

end.

4)

var

  a: 1000..9999;

  a1, a2, a3, a4: 0..9;

 

begin

  writeln('введите натуральное четырехзначное число');

  readln(a);

  a1: = a div 1000;   //тысячи

  a2: = (a mod 1000) div 100;   //сотни

  a3: = (a mod 100) div 10;   //десятки

  a4: = a mod 10;   //единицы

  writeln('полученное число:   ', a4, a3, a2, a1);

end.

все остальное делается наподобие этого: просто в writeln меняешь местами цифры и все.

   

0,0(0 оценок)
Ответ:
uzil1565
uzil1565
19.03.2022 18:11

3. CREATE TABLE

нужны имя полей и тип их данных, например уникальный ID это id = PRIMARY KEY

текст = text , не пустой текст = TEXT NOT NULL ,

числа = REAL,INT время = DATE и т.д

6. SELECT, FROM, GROUP BY, WHERE, ORDER BY, HAVING

7. SELECT - указывает , что извлекать из таблицы, так же может содержать агрегирующие функции и функции времени такие как EXTRACT, DATE_TRUNC

8. FROM - указывает из какой таблицы извлекать, так же можно указать подзапрос

9. WHERE - указывает какие условия нужны для извлечения , которые указаны в SELECT, не может сравнивать агрегирующие функции , для этого есть HAVING, также может содержать подзапрос

10. GROUP BY - групирует по .., HAVING - то же самое , что WHERE , только для агрегирующих функций

11. ORDER BY - использует методы ASC(по возрастанию значений) пример - имя_поле ASC, или DESC(по убыванию значений) - имя_поля DESC

Объяснение:

Будут вопросы напиши в коменты(

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота