В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
xastek
xastek
28.06.2020 08:18 •  Информатика

CРОЧНО! Решите задачу на C++ Даны два числа a и b. Ваша программа должна поменять два числа местами, если a
Формат входных данных
Даны два целых числа a и b (∣∣a∣∣,∣∣b∣∣≤109).

Формат выходных данных
Требуется вывести числа в том же формате, в котором они вводились.

входные данные
3 5
5 3
выходные данные
11 4
11 4

Показать ответ
Ответ:
TimRus162rusg
TimRus162rusg
27.11.2020 14:12

Условие:

Даны два числа: a и b. Ваша программа должна поменять два числа местами, если a < b, после чего вывести их.

#include <iostream>

#include <clocale>

using namespace std;

int main()

{

   setlocale(LC_ALL,"Russian");

   int a, b;

   cout << "Введите a, b: ";

   cin >> a >> b;

   if (a < b)

   {

       swap(a, b);

   }

   cout << a << " " << b;

}

Объяснение:

#include <iostream>  // Библиотека ввода-вывода

#include <clocale>  // Библиотека для локализации (возможно, будет работать без нее)

using namespace std;  // Пространство имен

int main()

{

   setlocale(LC_ALL,"Russian");  // Локализация (возможно, будет работать без нее)

   int a, b;  // Создание целочисленных переменных

   cout << "Введите a, b: ";  // Вывод текста в консоль

   cin >> a >> b;  // Вводим с клавиатуры

   if (a < b)  // Если а < b

   {

       swap(a, b);  // Меняем a и b местами

   }

   cout << a << " " << b;  // Вывод а и b через пробел

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота