CРОЧНО РЕШИТЬ НА Python 3 Через 'for i in range' без 'abs,while'
Даны натуральное число n и вещественные числа b1, b2, ..., bn. Определите сумму тех вещественных чисел, которые больше заданного p.
Формат входных данных
Вводятся целое число n (1≤n≤1000), вещественные числа p, b1, ..., bn, которые не превосходят по модулю 105, заданы с двумя знаками после запятой
Требуется вывести искомую сумму
входные данные:
5
2.44
1.66
-1.66
66.72
123.45
-66.13
выходные данные:
190.170000
c:array of array of integer;
ma:array of array of integer;
i,j,n:integer;
begin;
randomize;
readln(n);
setlength(a,n+1); //задаём размерность динамических массивов
setlength(c,n+1);
setlength(ma,n+1);
for i:=1 to n do
begin;
setlength(a[i],n+1);
setlength(c[i],n+1);
setlength(ma[i],n+1);
end;
writeln('Matrix A:'); //генерируем массив псеводслучайных чисел
for i:=1 to n do begin;
writeln;
for j:=1 to n do
begin;
a[i,j]:=random(10);
write(a[i,j]:4);
end;
end;
writeln;
writeln('Matrix C:'); //аналогично
for i:=1 to n do
begin;
writeln;
for j:=1 to n do
begin;
c[i,j]:=random(10);
write(c[i,j]:4);
end;
end;
for i:=1 to n do //сохраняем матрицу C для транспонации
for j:=1 to n do
ma[i,j]:=c[i,j];
writeln;
writeln('Transpose matrix C:'); //транспонируем C
for i:=1 to n do
begin;
writeln;
for j:=1 to n do
begin;
c[i,j]:=ma[j,i];
write(c[i,j]:4);
end;
end;
writeln;
writeln('Final matrix:'); // получаем финальную матрицу
for i:=1 to n do
begin;
writeln;
for j:=1 to n do
begin;
ma[i,j]:=2*c[i,j]*a[i,j];
{по свойству дистрибутивности матриц С(A+A)=C*A+C*A=2*C*A}
write(ma[i,j]:4);
end;
end;
end.
5. а) материнская плата б) жёсткий диск
7. информация-это любые сведения ,принимаемые и передаваемые, сохраняемые различными источниками.
1вид: текстовая
2вид:звуковая
3вид:числовая
8.
1) перенос информации ,мыслей в виде текста
пример:книга, документы ,журналы и т.д
2) это вид информации, в основе которой лежат звуковые колебания.
пример: человеческая речь, музыка и т.д
3) это информация выраженная в виде специальных символов:чисел,цифр
пример: ценники в магазинах, данные различных приборов , математические примеры и т.д
Объяснение:
можно лучший ответ