В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
norley15
norley15
11.07.2021 07:44 •  Информатика

Циклы!

ниже записана программа. получив на вход число x , эта программа печатает два числа, l и m. укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 10.

var x, l, m: integer;

begin

readln(x);

l : = 0;

m : = 0;

while x > 0 do

begin

l : = l + 1;

if m < x then begin

m: =(x mod 10)*2;

end;

x : = x div 10;

writeln(l);

writeln(m);

end.

максимальное число у меня - 959.
но я не уверенна

Показать ответ
Ответ:
elenachemiris
elenachemiris
09.12.2021 23:34
Просто скопируй и вставь в компилятор, все работет, проверенно
только в том месте где ф-цию вызываешь - znanija(a,b), просто ставишь другие числа, и тогда возвратится другое значение. Розбирайся вобщем)

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

namespace ConsoleApplication1
{
    class Program
    {
        static void Main(string[] args)
        {
            Console.WriteLine(znanija(6, 6));
            Console.ReadKey();
        }

        static char znanija(int a, int b)
        {
            if (a > b)
            {
                return '>';
            }
            else if (a < b)
            {
                return '<';
            }
            else
            {
                return '=';
            }
              
            
        }
    }

}
0,0(0 оценок)
Ответ:
SandruhA
SandruhA
19.06.2022 05:25

Объяснение:

Первыми переправляются дети.  

Сын возвращается к маме-папе.  

Папа едет на берег к дочери, потом дочь едет за братом и возвращается с ним к папе.  

Сын едет к маме, отдает ей лодку, чтобы она переплыла к папе и дочери.  

После того, как мама переправилась, дочь садится в лодку и едет к брату, подбирает его, и вместе они едут к родителям.  

Дочь остается с родителями, а сын едет к рыбаку, отдает ему лодку.  

Рыбак едет к родителям и высаживается.  

Дочь садится и едет за братом, привозит его с собой обратно (наконец-то вся семья снова вместе), они отдают лодку рыбаку.  

Лодка пересекла реку 13 раз.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота