В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Darvin2004
Darvin2004
30.03.2020 08:15 •  Информатика

Чуваки, . не шарю совсем, надо написать программу и лучше с объяснениями. дано натуральное число. верно ли, что в данном числе нет данной цифры а (цифру а вводить с клавиатуры)

Показать ответ
Ответ:
GeCUri
GeCUri
09.08.2020 07:51
Требуемая программа:
var n,a: longint; b: boolean;
begin
readln(n);
readln(a);
b:=false;
while n>0 do
 begin
 if n mod 10 = a then b:=true;
 n:=n div 10;
 end;
if b 
 then writeln('В числе есть введенная цифра')
 else writeln('В числе нет введенной цифры');
end.

Пример:
1236548
2
В числе есть введенная цифра
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота