В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
inber657205
inber657205
04.02.2022 20:11 •  Информатика

Чем отличается программа от алгоритма? а описания б) уровнем реализации в) различными исполнителями г) всеми названными и параметрами

Показать ответ
Ответ:
aimsen
aimsen
19.08.2022 13:35

===== C++ 17 =====

#include <iostream>

using namespace std;

int main()

{

   srand(time(NULL));

   int n = 12, k = 3;

   int a[k][n];

   for(int i = 0; i < k; i++)

   {

       for(int j = 0; j < n; j++)

       {

           a[i][j] = (rand() % 35 + 25) * 1000;

           cout << a[i][j] << " ";

       }

       cout << endl;

   }

   cout << "\nОбщая сумма, выплаченная всем работникам: ";

   int s = 0;

   for(int i = 0; i < k; i++)

       for(int j = 0; j < n; j++)

           s += a[i][j];

   cout << s << "\nЗарплаты каждого работника за квартал:\n";

   s = 0;

   for(int j = 0; j < n; j++)

   {

       s = 0;

       for(int i = 0; i < k; i++)

       {

           s += a[i][j];

       }

       cout << s << " ";

   }

   cout << "\nОбщие зарплаты всех работников по месяцам: ";

   for(int i = 0; i < k; i++)

   {

       s = 0;

       for(int j = 0; j < n; j++)

       {

           s += a[i][j];

       }

       cout << s << " ";

   }

   cout << endl;

   return 0;

}


Напишите программу на с++ известна зарплата каждого из 12 работников фирмы за каждый месяц первого к
0,0(0 оценок)
Ответ:
yayiliya
yayiliya
22.12.2020 15:07

103F

Объяснение:

Исходя из сути задания понимаем, что конечно число должно быть шестнадцатеричным, соответственно для 4-х значного такого числа необходимо заложить 16 символов " ", так как одно число состоит из 4 значений.

Так как необходимо взять наименьшее число, то первое значение должно быть 1, соответственно, обращаясь к таблице, где:

0 = 0 0 0 0

1 = 0 0 0 1

2 = 0 0 1 0

. . .

и т.д.

первый блок числа будет равен  "0 0 0 1".

Далее указывает 6 значащих нулей. Получаем "0001 0000 00хх ".

Остальные неизвестные заполняем 1, так как все необходимы 0 уже на месте. Получаем значение "0001 0000 0011 1111".

Переводим получившийся ответ в шестнадцатиричную систему счисления получив число "103F"

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота