Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
nikita2024
19.01.2021 16:11 •
Информатика
C++. составьте программу, где вводят 4-значное натуральное число и переставляет его первую и последнюю цифру. например, 3456 должно получиться 6453
Показать ответ
Ответ:
Андріана1323
08.10.2020 11:26
#include <iostream>
using namespace std;
int main() {
int n;
cin >> n;
int a = n % 10, b = (n / 10) % 10, c = (n / 100) % 10, d = n / 1000;
cout << a * 1000 + c * 100 + b * 10 + d;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
WANNNO
30.08.2021 18:32
Дан массив x(n,m) и число z.определить сколько раз среди элементов честных строк массива встречается число z с заданным значением...
DarthVader111103
30.08.2021 18:32
Напишите программу, которая объединяет возможности программ добавление в телефонный справочник и поиск в телефонном справочнике. при запуске программы на экран должно выводиться...
minikisa2007
30.08.2021 18:32
Возможна ли переписка в инете, если судно в открытом море...
ПомошницаНомер1
30.08.2021 18:32
Напишите программу печати таблицы перевода расстояний из дюймов в сантиметры (1 дюйм = 2,5 см) для значений длин от 1 до 20. qbasic...
Lee35
20.02.2020 20:18
Вывести на экран в строку через пробел такие трёхзначные числа у которых произведение 1 и 3 цифр равно введённому с клавиатуры числу...
lllgglll
24.02.2022 23:32
For13°. дано целое число n ( 0). найти значение выражения 1.1 – 1.2 + 1.3 – … (n слагаемых, знаки чередуются). условный оператор не использовать. через бэйсик желательно...
Бубух
06.04.2023 23:50
Не обновляется система emui до 9. у меня телефон honor 8x и пишет что последнее обновление 8.2.0. как обновить? ...
777496
24.01.2022 22:01
Составить 11 предложений. Пример: You can buy a pair of shoes in the shoe shop....
VladDzundza
11.03.2022 13:31
Сколько человек бежало со Спартаком из школы гладиаторов? 2. После чего в войске Спартака появилась конница? 3. В долине какой реки восставшие одержали победу над наместником...
matumaxim
02.02.2023 19:27
Даю корону 1)Какова численность в России? 2)сколько жителей в Москве, Санкт-Петербург?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
using namespace std;
int main() {
int n;
cin >> n;
int a = n % 10, b = (n / 10) % 10, c = (n / 100) % 10, d = n / 1000;
cout << a * 1000 + c * 100 + b * 10 + d;
}