В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
MrFear41
MrFear41
09.02.2020 19:15 •  Информатика

C++ ПОЛНАЯ ПРОГРАММА НОК
Напишите программу, которая вычисляет наименьшее общее кратное двух чисел.

Входные данные

Входная строка содержит два натуральных числа, разделённые пробелом, — a и b. Гарантируется, что ответ не превосходит 2⋅10^9
Выходные данные

Программа должна вывести одно натуральное число: НОК заданных чисел.

Примеры
Ввод
14 21
Вывод
42

Показать ответ
Ответ:
hekyljana156
hekyljana156
19.07.2022 15:02

Объяснение:

#include <iostream>

using namespace std;

long nod (int a, int b)  {

   return b == 0 ? a : nod (b, a % b);

}

int main() {

   int t1, t2;

   cin >> t1 >> t2;

   cout <<  t1 * (t2 / nod (t1, t2));

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота