В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
eeee1931
eeee1931
26.04.2022 17:18 •  Информатика

C++. Одномерные массивы. Задача 2.2

Дан одномерный массив, элементы которого — целые числа. Удалите из него все максимальные элементы.

Формат входных данных
В первой строке входного файла дано число N — количество элементов в массиве (1≤N≤100). В следующей строке находится N чисел, по абсолютному значению не превосходящих 1000.

Формат выходных данных
В выходной файл выведите полученный массив. При выводе разделяйте элементы массива пробелом.

Примеры:
Вход
4
9 8 7 5
Выход
8 7 5
Вход
6
-5 10 10 -6 -6 3
Выход
-5 -6 -6 3

Одномерные массивы. Задача 2.3

Дан одномерный массив, элементы которого — целые числа, и два целых числа L и R. Удалите из массива все элементы x такие, что L≤x≤R.

Формат входных данных
В первой строке входного файла даны три целых числа: N, L и R (−1000≤L≤R≤1000), где N — количество элементов в массиве (1≤N≤100). В следующей строке находится N чисел, по абсолютному значению не превосходящих 1000.

Формат выходных данных
В выходной файл выведите полученный массив. При выводе разделяйте элементы массива пробелом.

Примеры:
Вход
4 7 9
9 8 7 5
Выход
5
Вход
6 -6 0
-5 10 13 -6 -6 3
Выход
10 13 3

Показать ответ
Ответ:
Liz1ka
Liz1ka
27.11.2022 22:44
1. закончите предложение: «моделью называют объект, имеющий…» - существенные признаки объекта-оригинала 2. закончите предложение: «можно создавать и использовать …» - разные модели объекта 3. укажите примеры информационных моделей: - карта - график зависимости расстояния от времени - выкройка фартука - схема метро 4. укажите примеры знаковых информационных моделей: - словесное описание - формула 5. отметьте пропущенное слово: «формула для вычисления площади прямоугольника является примером … модели» - знаковой 6. отметьте пропущенное слово: «атлас автомобильных дорог является примером … модели» - смешанной 7. укажите пары объектов, о которых можно сказать, что они находятся в отношении «объект – модель»: - болт – чертеж болта - мелодия – нотная запись мелодии
0,0(0 оценок)
Ответ:
makskot69
makskot69
02.12.2020 03:02
1)var n,k: integer; begin   write('число:   ');   readln(n);   k: =0;   repeat     k: =k*10+n mod 10;     n: =n div 10;   until n=0;   writeln('новое число:   ',k); end. 2) var n,k,m: integer; begin  write('двоичное число:   ');   readln(n);   k: =1;   m: =0;   repeat    m: =m+k*(n mod 10);     n: =n div 10;     k: =k*2;   until n=0;   writeln('десятичное число:   ',m); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота