C++ Напишите программу, которая находит все цифры, которых нет в переданной ей строке.
Входные данные
На вход программа подаётся символьная строка.
Выходные данные
Программа должна вывести в одной строке все цифры, которые не встречаются в исходной строке, в порядке убывания. Если таких цифр нет, нужно вывести слово 'NO'.
Создать файл X компонентами которого являются элемента массива M. Переписать из файла X в файл Y все компоненты, которые стоят на четных местах. Прочитать файл Y.
M = (0,1; 5,6; 0.8; 2,4; 7,3; 6,8; 0,5; 2,3;)
Решение
Описание переменных:
M - массив-константа;
x, y - переменные, связанные с типизированными файлами;
n - считанное из файла очередное число;
i - счетчик.
Алгоритм решения задачи:
Создать константу-массив, присвоив ей заданные значения массива.
Связать файловые переменные с соответствующими файлами.
Открыть файл X на запись. Записать в него все элементы массива. Закрыть файл.
Открыть файл X на чтение, а файл Y на запись. Присвоить счетчику значение 1. Пока не будет достигнут конец файла X, считывать из него очередное число. Если при этом счетчик имеет четное значение, то записывать число в файл Y. После считывания и проверки на четность номера очередного числа, увеличивать счетчик на 1. После того как файл X будет прочитан, закрыть оба файла.
Открыть файл Y на чтение. Пока не будет достигнут его конец, считывать из него очередное число и выводить его на экран. После завершения цикла закрыть файл.
Программа на языке Паскаль:
const M: array[1..8] of real = (0.1, 5.6, 0.8, 2.4, 7.3, 6.8, 0.5, 2.3);
var
x,y : file of real;
n: real;
i: byte;
begin
assign(x,'x.dat');
assign(y,'y.dat');
rewrite(x);
for i:=1 to 8 do
write(x, M[i]);
close(x);
reset(x);
rewrite(y);
i := 1;
while not EOF(x) do begin
read(x, n);
if not odd(i) then
write(y, n);
i := i + 1;
end;
close(x);
close(y);
reset(y);
while not EOF(y) do begin
read(y, n);
write(n:5:1);
end;
writeln;
close(y);
Объяснение:
1. Дано равнобедренный треугольник АВС один из углов равен 92 °. Найти остальные углов. 2. Найти углы треугольника, если они относятся как 2: 6: 10. 3. Найти сумму внешних углов треугольника, если два внутренних углов равны 35 ° и 76 °. 4. Угол между биссектрисой BL и катетом АС прямоугольного треугольника АВС (угол С = 90 °) равен 55 °. Найти острые кутитрикутника АВС. 5. Один из внутренних углов треугольника на 10 ° больше другого. А внешний угол при третьей вершине равна 120 °. Найти углы треугольника. 6. В треугольнике АВС угол С = 90 °, угол А = 30 °, отрезок ВM - биссектриса угла, найти катет АС.