В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Рыжик151
Рыжик151
18.01.2023 03:33 •  Информатика

C++ Напишите программу, которая ищет медиану массива – элемент, делящий его на две равные части: в одной находятся элементы, которые не меньше медианы, в другой -– не больше медианы.

Есть далеко неполный код этой задачи, я пытался разными решить, но всё тщетно

Вот код:

void qSort( int nStart, int nEnd )

{

int L, R, c, X;

if ( nStart >= nEnd ) return;

L = nStart; R = nEnd;

X = A[(L+R)/2];

while ( L X ) R --;

if ( L <= R ) {

c = A[L]; A[L] = A[R]; A[R] = c;

L ++; R --;

}

}

qSort ( nStart, R );
qSort ( L, nEnd );

}

Показать ответ
Ответ:
irinkailnitska11
irinkailnitska11
31.10.2021 20:18

Пример на языке с++, дошел только для этого

#include<iostream>

using namespace std;

int min(int a, int b, int c, int d)

{

 int min1 = 0;

 int min2 = 0;

 if (a < b)

 {

  min1 = a;

 }

 else

 {

  min1 = b;

 }

 if (c < d)

 {

  min2 = c;

 }

 else

 {

  min2 = d;

 }

 if (min1 < min2)

 {

  cout << "Наименьшее из чисел: " << min1 << endl;

 }

 else

 {

  cout << "Наименьшее из чисел: " << min2 << endl;

 }

 return 0;

 

 

 

 

}

int main()

{

setlocale(LC_ALL,"RUSSIAN");

min(10,20,30,40);

 

return 0;

 

}

0,0(0 оценок)
Ответ:
саша4005
саша4005
20.04.2022 13:53
Чтобы проверить файловую систему флешки, нужно открыть «Мой компьютер» .  

 

Правой кнопкой мыши щелкните по значку флешки (съемного диска) . Откроется контекстное меню, в нем выберите пункт «Свойства» . Откроется диалоговое окно, в нем нужно открыть вкладку «Сервис» и в ней нажать на кнопку «Выполнить проверку... » В открывшемся диалоговом окне установите флажки «Автоматически исправлять системные ошибки» и «Проверять и восстанавливать поврежденные сектора» . Потом нажмите кнопку «Запуск» и ждите окончания проверки.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота