В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

C++

написать программу, определяющую максимальное из всех последовательно введенных чисел. (признаком окончания ввода чисел является ответ на вопрос: закончить ввод чисел? y/n. в виде нажатия клавиши y. в случае нажатия клавиши n ввод чисел продолжается. предусмотреть вариант, когда пользователь может нажать другой символ, кроме y и n).

Показать ответ
Ответ:
ария27
ария27
23.09.2021 00:23
Максимальное число, составленное из утроенного произведения цифр  будет 
9*3*N  -  не  может быть больше 54,  т.е.  
N может быть только 1 или 2.  По условию х>=10  ->  N=2  (N -порядок числа).
Поэтому искать нужно среди чисел от 11 до 54.  Решение - число 15.

var n,m: integer;
begin
  write('n = ');  readln(n);
  if n=2 then
  begin    m:=11;
    repeat
      if (m mod 10)*(m div 10)*3=m then
      begin
        writeln('число:  ',m);
        m:=55;
      end;
      m:=m+1;
    until m>54;
  end
  else  writeln('нет решения');
end.
0,0(0 оценок)
Ответ:
oleglebedev90
oleglebedev90
08.03.2023 00:56
1)  there  are  4  rooms  in  this  house.  (подставите  количество  сами,  т.к.  не  вижу  в  каком  2)there  are  2  bedrooms  in  this  house. 3) there    in  his  living  (аналогично  на  остальные  вопросы),  т.к.  не  видно  картинки,  чтобы  вам    перечислить,что  в  зале,  в  обеденной  комнате,  ванне,  спальне  и  ученическом  столе).
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота