C++ написать программу ! do while для новичков ! дана непустая последовательность целых чисел, оканчивающаяся отрицательным числом. необходимо определить, равны ли между собой все элементы последовательности. отрицательное число членом последовательности не является.
формат выходных данных
выведите «yes», если условие выполняется, и «no» в противном случае.
1 no
2
3
4
5
-1
#include <iostream>
using namespace std;
int main () {
int n;
cin >> n;
if (n==0) {
cout << "0 0" << endl << 1 << endl << 1 << endl;
return 0;
}
int mx=0; int mn=10; int mxi=10; int mnk=0; int ind=0;
while (n>0) {
int c=n%10;
n/=10;
if (c>=mx) {
mx=c;
mxi=ind;
}
if (c<mn) {
mn=c;
mnk=1;
} else if (c==mn) ++mnk;
++ind;
}
cout << mx << " " << mn << endl << (ind - mxi) << endl << mnk << endl;
return 0;
}
Объяснение: