В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
tseykalo18
tseykalo18
02.04.2020 10:16 •  Информатика

C/c++ составить программу возведения натурального числа n в квадрат, учитывая такую закономерность: 1 ^ 2 = 1, 2 ^ 2 = 1 + 3, 3 ^ 2 = 1 + 3 + 5, 4 ^ 2 = 1 + 3 + 5 + 7, п ^ 2 = 1 + 3 + 5 + 7 + 9 + + 2n-1. не использовать операцию умножения!

Показать ответ
Ответ:
geliebtemutter
geliebtemutter
09.10.2020 01:51

#include <iostream>


using namespace std;


int main() {

long int i, number, square = 0;


jump:

cout << "Input a natural number: ";

cin >> number;

if (number <= 0) {

             cout << "Input error! Try again"<< endl;

             goto jump;

}


for(i = 1; i <= number; i++)

              square += i + i - 1;


cout << "The square of number " << number << " is " << square << endl;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота