В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Илья0956
Илья0956
08.05.2023 03:34 •  Информатика

C/c++.

найдите наименьший четный элемент массива. если такого нет, то выведите первый элемент.

Показать ответ
Ответ:
Uprava78
Uprava78
04.10.2020 03:22

#include <iostream>

using namespace std;

int main() {

int n, k=0;

cin>>n;

int arr[n];

for (int i=0; i<n; ++i) {cin>>arr[i]; if (arr[i]%2==0&&(arr[i]<arr[k]||arr[k]%2==1)) k=i;}

cout<<arr[k];

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота