В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Yorgen1
Yorgen1
02.11.2022 11:48 •  Информатика

Быстрее 50 ! составить программу подсчета суммы s первых 1000 членов гармонического ряда 1+1/2+1/3+1/4+/n используя оператор цикла repeat.

Показать ответ
Ответ:
vasyamlodp0c2ay
vasyamlodp0c2ay
10.09.2020 08:49
Правильно подобный ряд начинать вычислять с меньших по величине членов - так будет выше точность.

// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (s,i):=(0.0,1000);
  repeat
    s+=1/i;
    i-=1;
  until i=0;
  Writeln(s)
end.

Результат
7.48547086055034

Во вложении приведено решение этой же задачи с точностью 20 цифр в пакете компьютерной математики Maple15. Видно,что все цифры, полученные программой, точны.
0,0(0 оценок)
Ответ:
LadyBoy357
LadyBoy357
10.09.2020 08:49
Program Summa;
Var   S:real;
      N:integer;
Begin
  S:=0;N:=0;
  repeat
    N:=n+1;
    S:=s+1/n
  Until n>1000;
  Writeln(s);
  Readln
End.


Быстрее 50 ! составить программу подсчета суммы s первых 1000 членов гармонического ряда 1+1/2+1/3+1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота