Билет №31. НА ЯЗЫКЕ PYTHON, КТО СКОЛЬКО МОЖЕТ
1. Определить и вывести на экран цифры целого числа n. Например: 568(первая цифра справа равна 8,вторая цифра равна 6..)Решить задачу необходимо через цикл While и построить блок схему.
2. Написать программу определения максимального числа последовательности положительных чисел. Решить задачу необходимо через «Любой Цикл» и построить блок схему.
3. У гусей и кроликов вместе 64 лапы. Сколько может быть кроликов и сколько гусей (указать все возможные сочетания) Решить задачу необходимо через For и построить блок схему.
4. Посчитать все отрицательные числа, положительные возвести в 5 степень и вывести на экран. (Числа задаются датчиком случайных чисел в диапазоне от -43 до 15 ). Решить задачу необходимо через if и построить блок схему.
5. По номеру дня вычислить числа и месяца не високосного года. Решить задачу необходимо через Оператор выбора и построить блок схему.
Формулы площадей квадрата S₁ и круга S₂ известны, что легко позволяет нам найти нужное условие.
Если нужно, чтобы случай, когда квадрат вписан в круг тоже учитывался, строгое неравенство следует заменить нестрогим.
// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
var s1:=ReadReal('Площадь квадрата');
var s2:=ReadReal('Площадь круга');
if pi*s1<2*s2 then Writeln('Квадрат умещается в круге')
else Writeln('Квадрат не умещается в круге')
end.
Тестовое решение:
Площадь квадрата 24.6
Площадь круга 28.4
Квадрат не умещается в круге
◘Достоверность информации. Ин-фа достоверна, если отражает истинное положение дел. (объективная информация всегда достоверна)
◘Полнота информации. Информация полная, если ее достаточно для понимания и принятия решения.
◘Точность информации. Определяется степенью ее близости к реальному состоянию объекта, процесса, явления и т.д.
◘Актуальность информации – важность для настоящего времени.
◘Полезность информации.
- Самая ценная информация – объективная, достоверная, полная, и актуальная.