В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

«бегущая строка». составить программу в паскале. которая изобразит в нижней части экрана строку, «бегущую» справа налево. строка должна менять свой цвет.

Показать ответ
Ответ:
sergio2014p06q4e
sergio2014p06q4e
03.10.2020 18:44
Uses CRT;

Const
Delay = 200; //Задержка в миллисекундах
Line = 22; //Номер строки, на которой будет текст
Text = 'Бегущая строка'; //Текст бегущей строки

Var 
i: Integer;
s: String;

Begin
  s := Text;
  For i := 1 To 80 Do
  Begin
    GotoXY(1, Line);
    TextColor(Random(14) + 1); 
    WriteLn(s);
    s := ' ' + s;
    Sleep(Delay);
  End;
End.
0,0(0 оценок)
Ответ:
ксюша1704
ксюша1704
03.10.2020 18:44
//Pascal ABC.NET 3.1 сборка 1256

uses
  GraphABC; 

Const
 s='Sample text';//текст
 d=10;//задержка

 Var
 x:integer;
begin
randomize;
x:=windowwidth;
while x>=0 do
 begin
  textout(x,windowheight-20,s); 
 setfontcolor(rgb(random(255),random(255),random(255)));
  sleep(d);
  dec(x);
  clearwindow;
 end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота