В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
filipp000
filipp000
22.07.2022 07:08 •  Информатика

B. бонусная программа
ограничение времени 1 секунда
ограничение памяти 32mb
ввод bonus.in
вывод bonus.out
магазин бытовой техники использует новую интерактивную бонусную программу. после очередной покупки клиенту приходит сообщение о начислении бонусных , причем сумма бонусов отображается в сообщении звездочками. под каждой звездочкой скрывается цифра. клиенту предлагают зачеркнуть наугад две любые рядом стоящие звездочки - цифры, после чего число октрывается и из него убираются вычеркнутые наугад покупателем две цифры. получившееся количество бонусов зачисляется на счет. например, клиенту пришло сообщение с такой суммой бонусов: . клиент наугад вычеркнул 3-ю и 4-ю звездочки. после чего число открылось: 735491. далее включилась анимация и вычеркнутые цифры исчезли: 7391. на бонусный счет покупателя зачисляется 7391 бонусных . откроем алгоритмический секрет. исходное число, представляемое системой в виде звездочек, действительно выбирается случайным образом из диапазона от 1000 до включительно. но перед тем, как оно отправится покупателю в виде звездочек, число поступает на вход контрольного модуля. этот модуль определяет, какое наибольшее количество бонусов придется начислить клиенту, в случае максимального везения клиента. в зависимости от ответа контрольного модуля система может заново перегенерировать число. ваша написать этот контрольный модуль.

формат ввода
в первой строке входного файла bonus.in приводится сгенерированное системой число в закодированном виде - в виде звездочек. в следующей строке - оно же, но уже в открытом виде.

формат вывода
в выходной файл следует записать максимальное количество бонусов, которое будет зачислено покупателю, если он наиболее удачно зачеркнет два разряда.

пример
ввод вывод

946024
9464

Показать ответ
Ответ:
mur181
mur181
01.02.2022 06:56

import java.util.Scanner;

public class Main {

  static int col=0;

   public static void main(String[] args) {

       Container c1 =new Container(10,4,2.5);

       v2(c1);

       System.out.println(col);

   }

   static void v2(Container container) {

       System.out.println("Ведите размеры авто");

       Scanner scanner = new Scanner(System.in);

       double l= scanner.nextInt();

       double h=scanner.nextInt();;

       double w=scanner.nextInt();;

       Car car = new Car(l,h,w);

       if (container.hashCode() >= car.hashCode()) {

           container.widht = container.widht - car.widht;

           container.height= container.height - car.height;

           container.leng = container.leng - car.leng;

            col++;

            v2(container);

           }

   }

}

public class Car {

    final double leng;

    final double height;

    final double widht;

   Car(double leng,double height,double widht){

       this.leng=leng;

       this.height=height;

       this.widht=widht;

   }

   @Override

   public int hashCode() {

       return (int) (leng+height+widht);

   }

}

public class Container {

    static double leng;

    static double height;

    static double widht;

   Container(double leng,double height,double widht){

       this.leng=leng;

       this.height=height;

       this.widht=widht;

   }

   @Override

   public int hashCode() {

       return (int) (leng+height+widht);

   }

}

0,0(0 оценок)
Ответ:
doblezor
doblezor
26.06.2021 11:13
var a, b: integer;
begin
 writeln('Введите часы: ');
 readln(a);
 writeln('Введите минуты: ');
 readln(b);
if (a > 6) and (a < 10) then writeln('Утро');
if (a = 10) and (b = 0) then writeln('Утро');
if (a = 6) and (b >= 30) then writeln('Утро');
if (a > 10) and (a < 16) then writeln('День');
if (a = 10) and (b >= 1) then writeln('День');
if (a = 16) and (b <= 30) then writeln('День');
if (a > 16) and (a < 22) then writeln('Вечер');
if (a = 22) and (b = 0) then writeln('Вечер');
if (a = 16) and (b >= 31) then writeln('Вечер');
if (a > 22) or (a < 6) then writeln('Ночь');
if (a = 22) and (b >= 1) then writeln('Ночь');
if (a = 6) and (b <= 30) then writeln('Ночь');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота