В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Алгоритм с подпрограммой (вс алгоритм).
Вспомнить как составляются подпрограммы (вс алгоритмы) Попробовать написать подпрограмму для рисования квадратика 2х2 и нарисовать 10 квадратов на поле в разных местах.
Составить программу для рисования «автобуса» см. рисунок.
Общее количество команд должно быть менее 67.

Показать ответ
Ответ:
contemplation22
contemplation22
02.01.2022 21:48

n = int(input('Введите количество элементов массива: '))

a = [int(input("Введите элемент массива: ")) for i in range(n)]

k = int(input("Введите любое число: "))

m = 0

for i in a:

   if i == k:

       m = m + 1

if m == 0:

   print ("NO")

else:

   print ("YES")

Объяснение:

Я немного подправила программу по синтаксису(были ошибки). А ещё не поняла, что нужно сделать, но вот два теста:

ТЕСТ 1:

ВВОД:

Введите количество элементов массива: 2

Введите элемент массива: 2

Введите элемент массива: 2

Введите любое число: 12

ВЫВОД ПРОГРАММЫ:

NO

ТЕСТ 2:

ВВОД:

Введите количество элементов массива: 2

Введите элемент массива: 12

Введите элемент массива: 12

Введите любое число: 12

ВЫВОД ПРОГРАММЫ:

YES

0,0(0 оценок)
Ответ:
nastyaorelrus
nastyaorelrus
26.01.2023 22:56

Существуют определенные стереотипы, вроде «авторитарный – плохо, а демократ – хорошо», к тому же у каждого есть определенный личный опыт или руководства, или общения с руководителями. Помимо личных предпочтений, нужно еще учитывать и объективную реальность. А реальность такова, что от сотрудников нужно добиться требуемых результатов, и методы достижения могут варьироваться в зависимости от личных данных и квалификации персонала, а также в зависимости от обстоятельств. Хороший менеджер меняет различные стили управления персоналом, используя весь арсенал средств мотивации и организации. Консалтинговая фирма Hay-McBer Associates выделяет шесть основных стилей управления персоналом:

1. Директивный (командный) стиль

Главная цель директивного стиля, который мы привыкли называть командным, - немедленное подчинение сотрудников.

Особенности:

Стиль общения «делай так, как я сказал»,

Непосредственный контроль подчиненных,

Мотивация дисциплиной и угрозами штрафных санкций.

Эффективно:

в кризисной ситуации,

когда разночтения и отклонения от курса несут большие риски.

Неэффективно:

низкий уровень развития персонала – они ничему не научатся;

высокий профессионализм подчиненных – они будут недовольны контролированием каждого шага, такой стиль будет восприниматься как недоверие и приводить к фрустрации.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота