В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Flash017
Flash017
08.10.2022 03:15 •  Информатика

Abcpaskal: с клавиатуры вводится строка, состоящая из букв и цифр. написать программу , определяющую количество четных цифр в

Показать ответ
Ответ:
komaman
komaman
26.06.2020 06:25
Uses crt;
var s1:string;
    s2:char;
    k,y,x:integer;
begin
     readln(s1);
     k:=0;
     for x:=1 to length(s1) do
         begin
              s2:=s1[x];
              if (ord(s2)<=57) and (ord(s2)>=48) then
                 if ord(s2) mod 2=0 then inc(y);
         end;
     writeln(y);
end.
0,0(0 оценок)
Ответ:
malenkayakreyz
malenkayakreyz
26.06.2020 06:25
Var
s1,s2:string;
i,j,k,m:longint;
begin
readln(s1);
k:=length(s1);
s2:='24680';
for i:=1 to k do
  for j:=1 to 5 do
    if s1[i]=s2[j] then inc(m);
writeln(m);
end.
ну вроде так, скомпилируй только перед отправкой или сдачей
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота