В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
sabegov1234
sabegov1234
06.03.2020 21:18 •  Информатика

9. напишите программу, которая вычисляет объём конуса. мова програмування c++

Показать ответ
Ответ:
creeperm477
creeperm477
06.09.2020 02:07

Создаёшь массив, заполняешь его, считаешь сумму и произведение, и обрабатываешь условие:


#include <stdio.h>

#include <stdlib.h>

#include <time.h>

#include <conio.h>

#define RANDOM_MIN -9

#define RANDOM_MAX 9

int main(void) {

srand(time(NULL)); /* for "visible" random */

 

int N;

scanf("%d", &N);

 

int *A = malloc(sizeof(int) * N);

int sum = 0;

int prd = 1;

 

printf("elements: ");

 

int i;

for (i = 0; i < N; i++) {

 A[i] = RANDOM_MIN + rand() % (RANDOM_MAX + abs(RANDOM_MIN) + 1);

 

 printf("%d ", A[i]);

 

 if (A[i] > 0) {

  sum += A[i];  

 } else if (A[i] < 0) {

  prd *= A[i];

 }

}

 

printf("\n");

printf("summa: %d\n", sum);

printf("product: %d\n", prd);

 

if (sum > prd) {

 int max = A[0];

 

 for (i = (0 + 1); i < N; i++) {

  if (max < A[i]) {

   max = A[i];

  }

 }

 

 printf("max element is: %d", max);

} else {

 printf("product higher than summa");

}

 

getch();

free (A);

return 0;

}

0,0(0 оценок)
Ответ:
даша3602
даша3602
17.07.2021 07:29

var a,b:integer;


c,d:real;


begin


a:=random(50); // Если нужно вводить своё число, то тогда "a:= *заданное число*" или, иначе, readln(a) "


writeln('Число "a" приняло значение ', a); // Если будет один из двух показанных выше, то эта строка не является обязательной.


b:=random(100); // Если нужно вводить своё число, то тогда "b:= *заданное число*" или, иначе, readln(b) "


writeln('Число "b" приняло значение ', b); // Если будет один из двух выше, то эта строка не является обязательной.


c:=((a+b)/2);


writeln('Среднее арифметическое данных двух чисел ', c);


d:=(sqrt(abs(a*b)));


writeln('Среднее геометрическое данных чисел ', d);


end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота