В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Killeris
Killeris
08.07.2021 16:01 •  Информатика

9. написать программу вычисления функции у: у=sqrt(х+5).если x> 0. у= sqrt(5+х), если x< =0 в случае отрицательного подкоренного выражения выводится надпись "останов" и программа заканчивается.

Показать ответ
Ответ:
NargizzaErbolat
NargizzaErbolat
07.10.2020 16:07
Программа вкратце.
Если посещал уроки то сможешь ее написать чтоб работала.
В условии задачи ошибка, наверное вместо - написал плюс.
y = sqrt(х+5). если x>0.
пусть здесь будет так: у= sqrt(5-х). если x<0

Program radical;
var x,y:integer;
Begin
readln(x);
if ((x+5) >= 0) and ((5-х) >=0)) then begin
   { проверка чтобы не-было меньше нуля }
    if (x>0) then 
       y = sqrt(x+5);
    else if (x<0) then 
       y = sqrt(5-x);
    writeln('результат=', y); 

   end
else 
    writeln("нельзя извлечь корень из отрицательного числа");

readln();

End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота