В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
rekrut234
rekrut234
03.12.2020 13:26 •  Информатика

8. написать программу, которая по выбору пользователя меняет цвет консольного приложения. пользователь может выбрать цвет шрифта и цвет фона.c++ if else

Показать ответ
Ответ:
lera956
lera956
11.08.2020 12:00

#include <iostream>

using namespace std;

void main() {

   setlocale(LC_ALL, "RUSSIAN");

   char text, fon;

   cout << "0 = Черный\t8 = Серый\n";

   cout << "1 = Синий\t9 = Светло - синий\n";

   cout << "2 = Зеленый\tA = Светло - зеленый\n";

   cout << "3 = Голубой\tB = Светло - голубой\n";

   cout << "4 = Красный\tC = Светло - красный\n";

   cout << "5 = Лиловый\tD = Светло - лиловый\n";

   cout << "6 = Желтый\tE = Светло - желтый\n";

   cout << "7 = Белый\tF = Ярко - белый\n\n";

   cout << "Введите цвет фона: ";      

   cin >> fon;

   cout << "Введите цвет текста: ";    

   cin >> text;

   switch (fon == text){

   case true:{cout << "Невозможно поменять цвета."; }

   case false:{

       switch (fon){

       case '0':{

           switch (text){

           case '1':{system("color 01"); break; }

           case '2':{system("color 02"); break; }

           case '3':{system("color 03"); break; }

           case '4':{system("color 04"); break; }

           case '5':{system("color 05"); break; }

           case '6':{system("color 06"); break; }

           case '7':{system("color 07"); break; }

           case '8':{system("color 08"); break; }

           case '9':{system("color 09"); break; }

           case 'a':{}

           case 'A':{system("color 0A"); break; }

           case 'b':{}

           case 'B':{system("color 0B"); break; }

           case 'c':{}

           case 'C':{system("color 0C"); break; }

           case 'd':{}

           case 'D':{system("color 0D"); break; }

           case 'e':{}

           case 'E':{system("color 0E"); break; }

           case 'f':{}

           case 'F':{system("color 0F"); break; }

           }break;

           switch (fon == text){

   case true:{cout << "Невозможно поменять цвета."; }

   case false:{

       switch (fon){

       case '1':{

       switch (text){

           case '1':{system("color 12"); break; }

       }break;

       }

       }break;

       }

       }break;

 

   }

   }

   

   cin.get(); cin.get();

}

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота