70 напишите программу для решения : торт весом т кг режут на порции. каждая порция торта весит р грамм. сколько гостей можно угостить тортом? программа должна запрашивать ввод необходимых данных и выводить ответ, который должен являться решением . через программу питон 3.5.2 пришлите файл
program pr10;
uses crt;
var
i: integer;
t: real; // рабочая переменная
i: byte; // счетчик массива
k: byte; // параметр цикла
a: array[1..15] of real;
n: byte; // размерность цикла
begin
clrscr;
write('введите размерность: ');
readln(n);
writeln('введите ',n,' элементов');
for i: =1 to n do
readln(a[i]);
writeln('исходный массив: ');
for i: =1 to n do
write(a[i]: 5: 1,' ');
readln;
// блок обработки
for k: =1 to n do
for i: =1 to n-k do
if(a[i]> a[i+1]) then
// перестановка
begin
t: =a[i];
a[i]: =a[i+1];
a[i+1]: =t;
end;
writeln('отсортированный массив: ');
for i: =1 to n do
write(a[i],' ');
writeln;
readln;
end.
я хз как правильно проверить простое число или нет. вот код, который просто сортирует массив по возрастанию.
type cl = class
a: integer;
constructor create(b: integer);
procedure setval(b: integer);
function getval: integer;
procedure sq;
end;
constructor cl.create(b: integer);
begin
a : = b;
end;
procedure cl.setval(b: integer);
begin
a : = b;
end;
function cl.getval: integer;
begin
getval : = a;
end;
procedure cl.sq;
begin
if a < 0 then
writeln('a ^ 2 = ', a * a)
else
writeln('error');
end;
var
obj: cl;
a : integer;
begin
write('a = ');
readln(a);
obj : = cl.create(a);
obj.sq;
readln;
obj.destroy;
end.