В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
irynks468dig
irynks468dig
25.09.2020 19:49 •  Информатика

6 Напишите программу, которая генерирует 10 случайных
чисел в диапазоне от -20 до 20, выводит эти числа на
экран И ВЫЧИСЛИТЬ:
A). Сумму и количество четных чисел; найти
квадратный корень из этой суммы.
Б) количество положительных чисел, среднее
арифметическое суммы положительных чисел.

Показать ответ
Ответ:
издательство1
издательство1
21.05.2022 08:06

#include <iostream>

#include <vector>

using namespace std;

int f(vector<int> &u){

   int k = 1;

   bool has_negative = false;

   for(auto &i : u){

       if(i < 0){

           k *= i;

           has_negative = true;

       }

   }

   return k * has_negative;

}

signed main(){

   const int n = 5;

   vector<vector<int>> a(n, vector<int> (n));

   for(int i = 0; i < n; i++)

       for(int j = 0; j < n; j++)

           cin >> a[i][j];

   for(int i = 0; i < n; i++)

       cout << "Product of negatives in " << i + 1 << " line is " << f(a[i]) << "\n";

}

0,0(0 оценок)
Ответ:
pupsikira2
pupsikira2
28.08.2020 22:58

Вариант 1:

using namespace std;

#include <iostream>

#include <clocale>

#include <cstdlib>

#include <iomanip>

#include <string>

int main() {

setlocale(LC_ALL, "rus");

system("chcp 1251");

srand(time(0));

double x;

cout << "Введите значение x" << endl;

cin >> x;

if (x <= 0)

 cout << pow(x, 4) << endl;

if (x > 0)

 cout << log10(x) << endl;

system("pause");

return 0;

}

Вариант 2:

using namespace std;

#include <iostream>

#include <clocale>

#include <cstdlib>

#include <iomanip>

#include <string>

int main() {

setlocale(LC_ALL, "rus");

system("chcp 1251");

srand(time(0));

double x;

cout << "Введите значение x" << endl;

cin >> x;

if (x >= 2)

 cout << sqrt(x) << endl;

if (x < 2)

 cout << log(3 - x) << endl;

system("pause");

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота