В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
JûšțĞîřł
JûšțĞîřł
05.03.2023 07:05 •  Информатика

58 за заполнение массива с паскаля нужно заполнить массив а(5,5) и распечатать его написать программу полностью

Показать ответ
Ответ:
minshinarena
minshinarena
10.06.2020 08:05

program raf105;

var

 a:array[1..5,1..5] of integer;

 i,j,o: integer;

begin

o:=-2;

for i:=1 to 5 do

begin

 writeln;

 for j:=1 to 5 do

 begin

   if (j<=3+abs(o)) and (j>=3-abs(o))

     then a[i,j]:=1

     else a[i,j]:=0;

   write(a[i,j],' ');

 end;

 o+= 1;

end;

end.

Язык PascalABC
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота